Home Excel - Downloads / Areas Restritas Excel VBA - Somarproduto

Excel VBA - Somarproduto

  • - Acesso Livre
  • Documentos

    Ordenar por : Nome | Data | Acessos [ Descendente ]

    Excel planilha formula somarprodutos valores meses Excel planilha formula somarprodutos valores meses

    popular!
    Adicionado em: 01/05/2011
    Modificado em: 01/05/2011
    Tamanho: 59.6 KB
    Downloads: 793

    Saberexcel - o site de quem precisa aprender Macros Microsoft Excel VBA

    Esse exemplo de planilha do Aplicativo Microsoft Excel, contém a Função SomarProduto(), que soma valores referente aos meses Janeiro, Fevereiro, Março, baseados em critérios, buscando em determinada tabela neste caso C2:C9 - e meses referentes.



    Fórmulas usadas...:
    =SOMARPRODUTO((MÊS($C$2:$C$9)=MÊS(J$1))*$A$2:$A$9)
    =SOMARPRODUTO((MÊS($C$2:$C$9)=MÊS(J$1))*($B$2:$B$9=DIREITA($G3;1))*$A$2:$A$9)



    Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel




    Publicidade
    Compre com segurança, garantia e ótimos preços
    Eletrônicos - Submarino.com.br

    Excel planilha vba somarproduto ocorrencia produtos Excel planilha vba somarproduto ocorrencia produtos

    popular!
    Adicionado em: 24/04/2011
    Modificado em: 24/04/2011
    Tamanho: 67.32 KB
    Downloads: 639

    Saberexcel - o site de quem precisa aprender Microsoft Excel VBA.

    Essa macro do Aplicativo Microsoft Excel VBA(Visual Basic Application), conta a ocorrencia de determinados produtos nas Colunas(B) e Coluna(C), essa macro representa a funcionalidade da Função SomarProduto(), com o mesmo resultado da fórmula:
    '=SOMARPRODUTO((B1:B10=C1:C10)*1)

    Option Base 1
    Sub Simulacao_macro_somarproduto()

    Dim vRegiao1 As Range, vRegiao2 As Range
    Dim vCelula1 As Range, vCelula2 As Range
    Dim i As Long, j As Long, z As LongB
    Dim aVerif() As String, bVerif As Boolean

    Set vRegiao1 = Range("B1:B16")
    Set vRegiao2 = Range("C1:C16")

    i = 0
    j = 0

    For Each vCelula1 In vRegiao1

    For Each vCelula2 In vRegiao2

    If vCelula2 = vCelula1 Then

    i = i + 1
    ReDim Preserve aVerif(i)

    If i = 0 Then

    aVerif(i) = vCelula2
    j = j + 1

    Else

    bVerif = False

    For z = 1 To UBound(aVerif)

    If aVerif(z) = vCelula1 Then bVerif = True

    Next z

    If bVerif = False Then

    j = j + 1
    aVerif(i) = vCelula2

    End If

    End If

    End If

    Next vCelula2

    Next vCelula1

    MsgBox "Há [ " & j & " ] - ocorrências no range[-[B1:B16]:[C1:C16]-]", vbInformation, "Saberexcel - site das Macros"

    End Sub






    Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel




    Publicidade
    Compre com segurança, garantia e ótimos preços
    Eletrônicos - Submarino.com.br

    Excel planilha vba somarproduto verifica ocorrencias_I Excel planilha vba somarproduto verifica ocorrencias_I

    popular!
    Adicionado em: 24/04/2011
    Modificado em: 24/04/2011
    Tamanho: 68.37 KB
    Downloads: 834

    Saberexcel - o site das macros

    Essa macro do Aplicativo Microsoft Excel VBA(Visual Basic Application), conta a ocorrência de deteminado produto em range renomeada por macro,
    neste caso o macro abaixo insere o nome de planiha vRegiao1, vRegiao2,
    'Fórmula inserida: =SOMARPRODUTO((vRegiao1=vRegiao2)*1)

    'Esse macro adiciona o nome em intervalos de Celulas(Range) vRegiao1 e vRegiao2
    Sub Adicionando_nomes_aos_range()
    ActiveWorkbook.Names.Add Name:="vRegiao1", RefersToR1C1:="=Somarproduto!R1C2:R10C2"
    ActiveWorkbook.Names.Add Name:="vRegiao2", RefersToR1C1:="=Somarproduto!R1C3:R10C3"
    Range("E10").Formula = "=SUMPRODUCT((vRegiao1=vRegiao2)*1)"
    End Sub

    'contando ocorrencia de produtos com macro
    Sub Somarproduto_ocorrencia_produtos()

    Dim vRegiao1 As Range, vRegiao2 As Range
    Dim vCelula1 As Range, vCelula2 As Range
    Dim i As Long

    Set vRegiao1 = Range("B1:B10")
    Set vRegiao2 = Range("C1:C10")
    i = 0

    For Each vCelula1 In vRegiao1
    For Each vCelula2 In vRegiao2
    'If vCelula2 = vCelula1 Then i = i + 1
    'If Trim(UCase(vCelula2)) = Trim(UCase(vCelula1)) Then i = i + 1
    If UCase(vCelula2) = UCase(vCelula1) Then i = i + 1
    Next vCelula2
    Next vCelula1

    MsgBox "Há [" & i & " ] " & "ocorrencias no intervalo de células [B1:C10]", vbInformation, "Saberexcel - site das macros"

    End Sub



    Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel





    Publicidade
    Compre com segurança, garantia e ótimos preços
    Eletrônicos - Submarino.com.br


    Google Associados

    Depoimentos

    Adicione Saberexcel Favoritos

     
     

    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


       Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA