Home Excel - Downloads / Areas Restritas Excel Formulas - Fracoes

Excel Formulas - Fracoes

  • - Acesso Livre
  • Documentos

    Ordenar por : Nome | Data | Acessos [ Descendente ]

    Excel Formulas formatar decimais e  area circulo polegada Excel Formulas formatar decimais e area circulo polegada

    popular!
    Adicionado em: 03/02/2011
    Modificado em: 03/02/2011
    Tamanho: 500.52 KB
    Downloads: 824

    Saberexcel - site das Macros

    Aprenderemos aqui a formatação de um número decimal em Fração e vamos fazer um calculo do raio de um círculo


    Essas frações me faz lembrar das aulas de matématica na matemática na 7 ª série, acho que todos lembram não é?, pois foi lá na sétima série que aprendi sobre calculos com frações, soma, divisão, subtração, multiplicação de fraçoes. Vamos supor que lhe passasse essa fração 135/864 e você teria de descobrir que o resultado seria
    5 / 32. Naquela época eu tinha pavor desses compostos aritméticos, tinha que descobrir que 999/864 resultava em 5 / 32 numa redução de fraçao. No excel a coisa pode se tornar bem mais simples e descomplicado veja como é fácil lidar com frações no Excel nos estilos personalizados principalmente, deveria ter isso naquela época!!!. Qualquer dia vou por em discussão com todos do grupo um assunto bacana sobre Funções do Excel - já desenvolví para os alunos de uma faculdade, todas as Worsheets Functions wkf worksheetfunction funções de planilhas retornam valores vba

    Aos meus amigos que acompanham meu trabalho, todos sabem que me esforço muito para ajudar a quem precisa, mas nem sempre é fácil ajudar a todos, pois o tempo é muito escasso.

    Voltando ao assunto, o formato personalizado de número é em forma de "# ??/???".
    A planilha simples a direita ilustra a fração de redução exemplo. Ligue o numerador na A1, o denominador em A2.

    Fiz um exemlo de planilha que voce poderá baixá-lo no final da página, o aplicativo Excel torna a fração em um número decimal em A3.
    A4 é o mesmo número, mas formatado como "# ??/???". O "#"(tralha) indica que, em uma fração mista, o inteiro deve aparecer em primeiro lugar, seguido por uma fração. Observem a simplicida com que o excel realiza e outras tarefas que manualmente seria mais trabalhoso.

    Para atribuir o formato personalizado, coloque o ponteiro da célula em A4, Formatar - Células - Número - Personalizadose digite # ??/??? no Tipo:
    OK, fim da aula de matemática 7 º ano. Outros usos mais relevantes no mundo dos negócios:

     As cotações de ações? Use o ??/??" "# formato de relatório em até 32 avos.
     Se você precisa relatório em 8 avos , utilize a formatação .....: "#? / 8"
     Se você precisa relatório em 10 avos, utilize a formatação......: "#? / 10"

    Esta fórmula usada foi desenvolvida para calcular o raio de um círculo.
    A resposta tem que ser em frações de uma polegada abaixo do próximo /16.
    Entretanto, precisamos reduzir 16/08 de 02/01, 10/16 a 08/05, etc

    =SE(MOD(INT(16*(+C6-INT(C6)+0,0312));16)=0;TEXTO(C6;"#");SE(MOD(INT(C6*(+C6-INT(C6)+0,0312));8)=0;TEXTO(C6;"# 0/2");SE(MOD(INT(16*(+C6-INT(C6)+0,0312));4)=0;TEXTO(C6;"# 0/4");SE(MOD(INT(16*(+C6-INT(C6)+0,0312));2)=0;TEXTO(C6;"# 0/8");TEXTO(C6;"# 0/16")))))

    VEJA A FÓRMULA COM QUEBRA DE LINHAS PARA FICAR MAIS FÁCIL O ENTENDIMENTO.
    =SE(MOD(INT(16*(+C6-INT(C6)+0,0312));16)=0;TEXTO(C6;"#");_
    SE(MOD(INT(C6*(+C6-INT(C6)+0,0312));8)=0;TEXTO(C6;"# 0/2"); _
    SE(MOD(INT(16*(+C6-INT(C6)+0,0312));4)=0;TEXTO(C6;"# 0/4");_
    SE(MOD(INT(16*(+C6-INT(C6)+0,0312));2)=0;TEXTO(C6;"# 0/8");_
    TEXTO(C6;"# 0/16")))))


    Não conseguimos encontrar um grande resposta para essa questão, então, fizemos essa fórmula que é capaz de mudar um o formato
    de número em um formato, mas não existe isso disponível até o momento no excel, talvez montanto uma função no VB.
    Se o resultado da fórmula é na célula C5, você pode colocar a seguinte fórmula em D2 para exibir corretamente o resultado:

    Augusto: Talvez isso possa ajudá-lo ou lhe forneça alguma pista para seu trabalho, Fique com Deus,

    .-

    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA 

     


    Google Associados

    Depoimentos

    Adicione Saberexcel Favoritos

     
     

    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


       Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA